最新 追記

いがいが日記


2015-02-02 [長年日記]

_ Nitrous.IO で Ruby と Rails をバージョンアップした

ひさびさに Nitrous.IO を使ったのでRuby 2.2.0 を使ってみた。
Rubyのバージョンアップは以前に日記に書いた。RVMが使われているので、RVMでRubyをバージョンアップすればいい。

  • $ rvm get stable
  • $ rvm install 2.2.0
  • $ rvm use global 2.2.0 --default

やってたらディスクに書き込めない旨のエラーが出て一瞬迷ったけど、ディスク容量が足りないだけだった。rvm uninstall 2.1.1 とかで削除したらうまくいった。

Ruby2.2.0 で Rails 4.2.0 を入れたら、rails s で起動してPreview から接続しても繋がらない。でも別コンソールで curl を叩くと繋がる。ぐぐったら以下にせよと。これで繋がった。Nitrous.IO + Rails4.2 で起きる問題みたい。

  • $ rails server -b, --binding=0.0.0.0

念のためNitrousにフィードバックしておいた。


最新 追記